iOS Users: Please click here for the latest information: (updated 5.10.2016)
Say It Right Series

i-phone app.

Posted by kohiroito June 26, 2010 in the Group General Discussion.

Yesterday I update my i-touch OS from 3.1 to 4.0. Then I cannot connect chinesepod server. Cannot Login. What should I do? App not support OS 4.0? Do you have update version for OS 4.0?

Comments (0) RSS

loading... Updating ...

To comment, please login.

Not sure if your comment is appropriate? Check our Commenting Policy first.

New lesson idea? Please contact us.